NumberVaryingLengthRebarsIndividually Property


Reinforcement Settings Number Varying Length Rebars Individually Property

Note: This API is now obsolete.

Use this option to modify the way varying length bars are numbered (individually or as a whole).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. We suggest you use the 'NumberingMethod' property instead.")]
public bool NumberVaryingLengthRebarsIndividually { get; set; }

Property Value

Boolean
Remarks
If this property is true it will correspond to [!:Autodesk::Revit::DB::ReinforcementNumberingMethod::NumberBarsIndividually] . If this property is false, it may correspond to [!:Autodesk::Revit::DB::ReinforcementNumberingMethod::AssignUniqueNumberPerSet] or [!:Autodesk::Revit::DB::ReinforcementNumberingMethod::MatchSetsWithIdenticalBars] . If you set it to true, it will correspond to [!:Autodesk::Revit::DB::ReinforcementNumberingMethod::NumberBarsIndividually] . If you set it to false, it will correspond to [!:Autodesk::Revit::DB::ReinforcementNumberingMethod::AssignUniqueNumberPerSet] .
See Also