GetChildIds Method


Gets the ids of the immediate children of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public ICollection<ElementId> GetChildIds()
Visual Basic
Public Function GetChildIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetChildIds()

Return Value

The element ids of all links which are linked directly into this one (immediate children)

Remarks

This function only returns the ids of immediate children. Given the link structure A -> B -> C, then calling this function on A will only return B's id.

See Also