Multiply Operator (Double, UV)


The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public static UV operator *(
	double value,
	UV right
)
Visual Basic
Public Shared Operator * ( _
	value As Double, _
	right As UV _
) As UV
Visual C++
public:
static UV^ operator *(
	double value, 
	UV^ right
)

Parameters

value
Type: System Double
The value to multiply with the specified vector.
right
Type: Autodesk.Revit.DB UV
The vector to multiply with the value.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions ArgumentNullException Thrown when right is a null reference ( Nothing in Visual Basic) .

See Also