GetValidCategoriesForMaterialTakeoff Method


Gets a list of categories that can be used for a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetValidCategoriesForMaterialTakeoff()
Visual Basic
Public Shared Function GetValidCategoriesForMaterialTakeoff As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidCategoriesForMaterialTakeoff()

Return Value

The IDs of all valid categories.

See Also