WallSweepInfo Constructor (WallSweepType, Boolean)


Constructs a new WallSweepInfo instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public WallSweepInfo(
	WallSweepType type,
	bool vertical
)
Visual Basic
Public Sub New ( _
	type As WallSweepType, _
	vertical As Boolean _
)
Visual C++
public:
WallSweepInfo(
	WallSweepType type, 
	bool vertical
)

Parameters

type
Type: Autodesk.Revit.DB WallSweepType
The type of the WallSweepInfo instance.
vertical
Type: System Boolean
True to construct a vertical wall sweep, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also