GetDistanceToTargetCover Method


Returns the distance from the RebarConstrainedHandle to the target Host Cover Element surface. The RebarConstraintType of the RebarConstraint must be 'ToCover.'

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public double GetDistanceToTargetCover()
Visual Basic
Public Function GetDistanceToTargetCover As Double
Visual C++
public:
double GetDistanceToTargetCover()

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToCover.'

See Also