GetParentId Method


Gets the id of this link's immediate parent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public ElementId GetParentId()
Visual Basic
Public Function GetParentId As ElementId
Visual C++
public:
ElementId^ GetParentId()

Return Value

The id of the immediate parent of this link, or invalidElementId if this link is a top-level link.

Remarks

This function returns the immediate parent id. Given the link structure A -> B -> C, then calling this function on C will return B's id. Call GetRootId to get A's id.

See Also