Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This data represents the contents to be shown to the user while they are browsing a specific folder in Revit.
The folder path can be obtained from the FolderPath property.
The external resource server is expected to populate all of the available resources and subfolders that should appear in the Revit file browser while the browser is open to this particular folder.
If the user navigates to another folder, a different ExternalResourceBrowserData object will be provided to allow the server to populate resources at that location.
When adding resource and sub folder, the resource and sub folder should not be added recursively.
When adding resource and sub folder, the name should be unique short name(without folder).
The name of resource and sub folder should not contain any invalid character of \/:*?"<>|.
The length of resource combined path(server name + folder path + resource name) should not exceed 259; The length of sub folder also has same restriction.