SetCategories Method


Sets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public void SetCategories(
	ICollection<ElementId> categories
)
Visual Basic
Public Sub SetCategories ( _
	categories As ICollection(Of ElementId) _
)
Visual C++
public:
void SetCategories(
	ICollection<ElementId^>^ categories
)

Remarks

Testing that an element's category is a member of this set is, essentially, the first rule of the filter.

Changing the set of categories will clear the element's filter rules.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also