Obtains the IFC type associated to the given element for the current export.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- element
- Type: Autodesk.Revit.DB Element
The element.
- exporterIFC
- Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
Return Value
The IFC type. This is an empty string if the element should not be exported because it is not found in the mapping file.Remarks
IFC type names are affected by the user's entries in the mapping file set for a given export operation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |