ElementsMatchReferenceCategory Method


Verifies that all of the elements match the reference category required by the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public bool ElementsMatchReferenceCategory(
	ICollection<ElementId> elements
)
Visual Basic
Public Function ElementsMatchReferenceCategory ( _
	elements As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool ElementsMatchReferenceCategory(
	ICollection<ElementId^>^ elements
)

Parameters

elements
Type: System.Collections.Generic ICollection ElementId
The elements to test.

Return Value

True if all the elements match the reference category required by the MultiReferenceAnnotationType.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also