CanAddEntry Method


Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public bool CanAddEntry(
	KeyBasedTreeEntry entry
)
Visual Basic
Public Function CanAddEntry ( _
	entry As KeyBasedTreeEntry _
) As Boolean
Visual C++
public:
bool CanAddEntry(
	KeyBasedTreeEntry^ entry
)

Parameters

entry
Type: Autodesk.Revit.DB KeyBasedTreeEntry
The KeyBasedTreeEntry object to be checked.

Return Value

True if the KeyBasedTreeEntry could be added in, otherwise false.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also