FindDefinitionType Method


Find a DirectShapeType element by definition id. The element will be used for creating instances of that definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public ElementId FindDefinitionType(
	string id
)
Visual Basic
Public Function FindDefinitionType ( _
	id As String _
) As ElementId
Visual C++
public:
ElementId^ FindDefinitionType(
	String^ id
)

Parameters

id
Type: System String
Definition id. Expected to be unique.

Return Value

Element id of a DirectShapeTypeElement

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also