GetRevisionNumberOnSheet Method


Gets the Revision Number for a particular Revision as it will appear on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public string GetRevisionNumberOnSheet(
	ElementId revisionId
)
Visual Basic
Public Function GetRevisionNumberOnSheet ( _
	revisionId As ElementId _
) As String
Visual C++
public:
String^ GetRevisionNumberOnSheet(
	ElementId^ revisionId
)

Parameters

revisionId
Type: Autodesk.Revit.DB ElementId
The id of the Revision.

Return Value

Returns the Revision Number as it will appear on this sheet or a null reference ( Nothing in Visual Basic) if the Revision does not appear on this sheet.

Remarks

Returns a null reference ( Nothing in Visual Basic) if the Revision does not appear on this sheet.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException revisionId is not a valid Revision.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also