Multiplies the two specified transforms.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- left
- Type: Autodesk.Revit.DB Transform
The first transformation.
- right
- Type: Autodesk.Revit.DB Transform
The second transformation.
Return Value
The transformation equal to the composition of the two transformations.Remarks
The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the handle of the first or second transformation is a null reference ( Nothing in Visual Basic) . |