SetFormatOptions Method


Sets the format options used to show the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2017 Subscription Update

Syntax

C#
public void SetFormatOptions(
	FormatOptions formatOptions
)
Visual Basic
Public Sub SetFormatOptions ( _
	formatOptions As FormatOptions _
)
Visual C++
public:
void SetFormatOptions(
	FormatOptions^ formatOptions
)

Parameters

formatOptions
Type: Autodesk.Revit.DB FormatOptions
The format options to be set.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException This DimensionEqualityLabelFormatting uses a LabelType which does not support assignment of FormatOptions.

See Also