CylindricalFace Class


A cylindrical face of a 3d solid or open shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)

Syntax

C#
public class CylindricalFace : Face
Visual Basic
Public Class CylindricalFace _
	Inherits Face
Visual C++
public ref class CylindricalFace : public Face

Remarks

For details on the parameterization, refer to the documentation for CylindricalSurface .

Examples

Copy C#
private void GetCylindricalFaceInfo(Face face)
{
    CylindricalFace cylindricalFace = face as CylindricalFace;
    if (null != cylindricalFace)
    {
       XYZ axis = cylindricalFace.Axis;
       XYZ origin = cylindricalFace.Origin;
       XYZ radius = cylindricalFace.get_Radius(0);
    }
}
Copy VB.NET
Private Sub GetCylindricalFaceInfo(face As Face)
    Dim cylindricalFace As CylindricalFace = TryCast(face, CylindricalFace)
    If cylindricalFace IsNot Nothing Then
        Dim axis As XYZ = cylindricalFace.Axis
        Dim origin As XYZ = cylindricalFace.Origin
        Dim radius As XYZ = cylindricalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

See Also