Inserts the single Fabric Sheet instance into the host element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hostElement
- Type: Autodesk.Revit.DB Element
A structural element that will host the Fabric Sheet. The element must support fabric hosting.
- transform
- Type: Autodesk.Revit.DB Transform
The transform that defines the placement of the instance single Fabric Sheet.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The host Element is not a valid host for Fabric Sheet. -or- transform defines the placement out of the host. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | transform is not conformal. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |