Gets the ExternalResourceReference associated with a specified external resource type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- resourceType
- Type: Autodesk.Revit.DB ExternalResourceType
The desired external resource type.
Return Value
The copy of the ExternalResourceReference associated with a specified external resource type.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This Element does not use a resource reference for the specified resource type. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |