Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameter
- Type: Autodesk.Revit.DB ElementId
A double-typed parameter used to get values from the document for a given element.
- value
- Type: System Double
The user-supplied value against which values from the document will be compared.
- epsilon
- Type: System Double
Defines the tolerance within which two values may be considered equal.
Remarks
Values greater than value but within epsilon are considered equal, not greater.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |