ActiveAddInId Property


Retrieves the Id of the currently running external application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic
Public ReadOnly Property ActiveAddInId As AddInId
	Get
Visual C++
public:
property AddInId^ ActiveAddInId {
	AddInId^ get ();
}

Remarks

The application can be either a UI application, DB application, or an external command. If no addin is active, this property will return a null reference ( Nothing in Visual Basic) . If an event handler is currently being executed, the returned value will be the Id of the application or command in which the event handler was registered.

See Also