Removes one or more subelements from a StructuralConnectionHandlerType. The subelements will be erased.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- structuralConnectionHandler
- Type: Autodesk.Revit.DB.Structure StructuralConnectionHandler
The existing StructuralConnectionHandler having custom StructuralConnectionHandlerType which is about to be modified.
- subelements
- Type: System.Collections.Generic IList Subelement
The main Subelements of input StructuralConnectionHandler which are to be used to modify custom StructuralConnectionHandlerType.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Input StructuralConnectionHandler must have custom type. -or- All the input Subelements must belong to input StructuralConnectionHandler. After modification of StructuralConnectionHandlerType there must remain at least one subelement of structural connections category in StructuralConnectionHandler. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |