Create a new pipe ConnectorElement with a face and an edge.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to add the connector to.
- pipeSystemType
- Type: Autodesk.Revit.DB.Plumbing PipeSystemType
The PipeSystemType of the connector.
- planarFace
- Type: Autodesk.Revit.DB Reference
The planar face to place the connector on.
- edge
- Type: Autodesk.Revit.DB Edge
One of the edges in the edge loop that defines the connector location on the planar face.
Return Value
The pipe ConnectorElement.Remarks
Regenerates the document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | Connector creation is not allowed in this family. |