DisconnectFromServer Method


Sets the GUID of the API server to invalid value and removes all the server related data from the Rebar (ex. the current constraints and the handle tags are removed). Calling this method will result in a Rebar that will not react to host changes anymore, however it will still have all the properties that it used to have.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public void DisconnectFromServer()
Visual Basic
Public Sub DisconnectFromServer
Visual C++
public:
void DisconnectFromServer()

Exceptions

Exception Condition
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions InvalidOperationException This RebarFreeFormAccessor doesn't contain a valid rebar reference.

See Also