ElectricalSystem Class


Provides access to the Electrical System in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2011

Syntax

C#
public class ElectricalSystem : MEPSystem
Visual Basic
Public Class ElectricalSystem _
	Inherits MEPSystem
Visual C++
public ref class ElectricalSystem : public MEPSystem

Remarks

The Electrical System object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

See Also