SetHookOrientationAngle Method


Set the hook orientation angle at end. Will throw exception if the rebar has valid constraints.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public void SetHookOrientationAngle(
	int end,
	double angle
)
Visual Basic
Public Sub SetHookOrientationAngle ( _
	end As Integer, _
	angle As Double _
)
Visual C++
public:
void SetHookOrientationAngle(
	int end, 
	double angle
)

Parameters

end
Type: System Int32
The end of bar. Should be 0 for start or 1 for end.
angle
Type: System Double
The hook orientation angle at end.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException Invalid end.
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions InvalidOperationException This RebarFreeFormAccessor Rebar is constrained.

See Also