Checks if the specified RebarHookType id is of a valid RebarHookType for the Rebar's RebarBarType
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- proposedHookId
- Type: Autodesk.Revit.DB ElementId
The Id of the RebarHookType
Return Value
Returns true if the id is of a valid RebarHookType for the Rebar element.Remarks
Also, checks that the Style of the Hook matches that of the Rebar's RebarShape
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |