Creates a duplicate of this PropertySetElement.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which to create the PropertySetElement.
- name
- Type: System String
The name to use for the new PropertySetElement.
Return Value
The new PropertySetElement.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value for name is already in use as a property set name. -or- name is an empty string. -or- name cannot include prohibited characters. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |