Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- point
- Type: Autodesk.Revit.DB XYZ
The point used to find elements with a bounding box that contains it.
- tolerance
- Type: System Double
The tolerance value to use instead of zero. See the tolerance property for details.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value for tolerance is not finite -or- The given value for tolerance is not a number |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |