Sets a single layer for this CompoundStructure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- layerIdx
- Type: System Int32
The index of a layer. This should range from 0 to the number of layers - 1.
- layer
- Type: Autodesk.Revit.DB CompoundStructureLayer
The layer to be set.
Remarks
This function does not support addition of new layers, use SetLayers() to change the number of layers.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The layer is not valid for this operation. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The layer index is out of range. |
Autodesk.Revit.Exceptions InvalidOperationException | This operation is valid only for non-vertically compound structures. |