SetLayer Method


Compound Structure Set Layer Method

Sets a single layer for this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetLayer(
	int layerIdx,
	CompoundStructureLayer layer
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
layer CompoundStructureLayer
The layer to be set.
Exceptions
Exception Condition
ArgumentException The layer is not valid for this operation.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The layer index is out of range.
InvalidOperationException This operation is valid only for non-vertically compound structures.
Remarks
This function does not support addition of new layers, use SetLayers() to change the number of layers.
See Also