If the DimensionStyleType is Linear, validates that the references are valid for an aligned multi-reference annotation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document for the multi-reference annotation.
- ownerViewId
- Type: Autodesk.Revit.DB ElementId
The view in which the multi-reference annotation will appear.
- options
- Type: Autodesk.Revit.DB MultiReferenceAnnotationOptions
Options containing the references which the dimension will witness.
Return Value
True DimensionStyleType does not equal Linear or if an aligned multi-reference annotation can be created from the references.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |