Creates a free placed hanger.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- button
- Type: Autodesk.Revit.DB FabricationServiceButton
The fabrication service button to use.
- condition
- Type: System Int32
The condition index. If the button has multiple conditions.
- levelId
- Type: Autodesk.Revit.DB ElementId
The level identifier associated with the level.
Return Value
The newly-created fabrication hanger.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Invalid fabrication service button. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | the index condition is not larger or equal to 0 and less than ConditionCount |