Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pGeomArr
- Type: System.Collections.Generic IList GeometryObject
Shape expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |