Verifies that the view represented by templateId can be set as the controlling view template for this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- templateId
- Type: Autodesk.Revit.DB ElementId
The id to be validated as a view template for this view.
Return Value
True if the view is valid for us as a view template and compatible with this view, or if it is InvalidElementId, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |