Retrieves a category object corresponding to a BuiltInCategory id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryId
- Type: Autodesk.Revit.DB BuiltInCategory
Remarks
Unlike the method that obtains categories by name, this routine will obtain the handle even of built-in subcategories. Since 2016 it is advised to use either [!:Autodesk::Revit::DB::Category::GetCategory(Document,BuiltInCategory)] or [!:Autodesk::Revit::DB::Category::GetCategory(Document,ElementId)] method from Category class.