Item Property (BuiltInCategory)


Categories Item(Built In Category) Property

Retrieves a category object corresponding to a BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public virtual Category this[
	BuiltInCategory categoryId
] { get; }

Parameters

categoryId BuiltInCategory

Property Value

Category
Remarks
Unlike the method that obtains categories by name, this routine will obtain the handle even of built-in subcategories. Since 2016 it is advised to use either Category.​​​GetCategory(​Document, ​BuiltIn​Category) or Category.​​​GetCategory(​Document,​ ElementId)​ from Category class.
See Also