SetCoverType Method


Associates the specified CoverType with the specified face of the element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public void SetCoverType(
	Reference face,
	RebarCoverType coverType
)
Visual Basic
Public Sub SetCoverType ( _
	face As Reference, _
	coverType As RebarCoverType _
)
Visual C++
public:
void SetCoverType(
	Reference^ face, 
	RebarCoverType^ coverType
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException In this element, face does not have an associated CoverType, because it is not exposed.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also