Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- location
- Type: Autodesk.Revit.DB XYZ
The physical location where the group is to be placed.
- groupType
- Type: Autodesk.Revit.DB GroupType
A GroupType object that represents the type of group that is to be placed.
Return Value
If creation was successful then an instance to the new group is returned, otherwise a null reference ( Nothing in Visual Basic) .Remarks
This method is used to place a new instance of an existing group type within the document. The group's origin will placed at the point specified by the location. All group types within the document can be found by iterating over the document and looking for elements of type GroupType .