Creates an analytical connection type element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document.
- name
- Type: System String
The name of the analytical type to be created.
Return Value
The created analytical connection type element.Remarks
The newly created type would have the default pressure loss being 0. Use ElementType.duplicate to copy from any existing type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This name is already used by an existing analytical connection type in the document. -or- name cannot include prohibited characters. -or- name is an empty string. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |