Constructs a new instance of a class used to calculate extrusions from Revit geometry.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
- extrusionAxes
- Type: Autodesk.Revit.DB.IFC IFCExtrusionAxes
The extrusion axes to try when doing the calculation.
- customAxis
- Type: Autodesk.Revit.DB XYZ
The custom axis to try (if extrusionAxes includes an option for a custom direction).
- scale
- Type: System Double
The scaling factor for length measurements from the default Revit units to the export units.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |