Retrieves the number of interior or exterior shell layers.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- shellLayerType
- Type: Autodesk.Revit.DB ShellLayerType
If ShellLayerType.Exterior return the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type). If ShellLayerType.Interior return the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).
Return Value
The number of shell layers in the interior or exterior shell, as specified by shellLayerType.Remarks
There will always be at least one core layer, i.e. one layer which is not a shell layer. You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32) .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |