GetNumberOfShellLayers Method


Compound Structure Get Number Of Shell Layers Method

Retrieves the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public int GetNumberOfShellLayers(
	ShellLayerType shellLayerType
)

Parameters

shellLayerType ShellLayerType
If ShellLayerType.Exterior return the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type). If ShellLayerType.Interior return the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).

Return Value

Int32
The number of shell layers in the interior or exterior shell, as specified by shellLayerType.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
There could be no core layers. You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32) .
See Also