Creates a new instance of a NumberSystem associated to a host element and a view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- viewId
- Type: Autodesk.Revit.DB ElementId
The view in which the NumberSystem will be created.
- numberedElementId
- Type: Autodesk.Revit.DB LinkElementId
The host id on which the NumberSystem will be created.
- referenceCurve
- Type: Autodesk.Revit.DB Reference
The reference curve along which the NumberSystem will be created. It is suggested to get the new reference via GetNumberSystemReference() from the host element.
Return Value
The created NumberSystem.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | viewId is not valid for placement of a NumberSystem (only floor plan views and elevation views are permitted). -or- numberedElementId is not valid as a host for NumberSystem (only StairsRun elements are permitted in this release). -or- The referenceCurve is not valid for NumberSystem on numberedElementId. -or- The numberedElementId already has a NumberSystem. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |