Add a new edge to the geometry being built. The BRepBuilder uses edges only to store edge geometry and to track pairs of co-edges that share an edge.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- edgeGeom
- Type: Autodesk.Revit.DB BRepBuilderEdgeGeometry
Information specifying the edge's geometry.
Return Value
Id of the edge, to be used in calls to other BRepBuilder methods such as AddCoEdge().Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input edge geometry was invalid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details. |