Identifies if the naming category is valid for an assembly instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document for the assembly instance.
- namingCategoryId
- Type: Autodesk.Revit.DB ElementId
The id of the naming category for the assembly instance.
- assemblyMemberIds
- Type: System.Collections.Generic ICollection ElementId
Member ids to check validity of naming category
Return Value
True if the naming category is valid, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |