Gets the Rebar Shape id for the bar with index barPositionIndex.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- barPositionIndex
- Type: System Int32
An index between 0 and (NumberOfBarPositions-1).
Return Value
Gets the ElementId of the Rebar Shape for the bar with index barPositionIndex.Remarks
If this function is called for the first bar or last bar in set and this is hidden, this function will throw exception.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- barPositionIndex is an index for the first or last bar which is hidden. |