Returns the ElementId of the (top-level) linked model with the given path.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to look for the linked model in.
- path
- Type: Autodesk.Revit.DB ModelPath
A path indicating which linked model to return.
Return Value
The id of the link with the given path, or InvalidElementId if there is no top-level link at that path.Remarks
This function will not return nested links.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |