Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- connector1
- Type: Autodesk.Revit.DB Connector
The first connector to be connected to the union.
- connector2
- Type: Autodesk.Revit.DB Connector
The second connector to be connected to the union.
Return Value
If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument connector1 or connector2 is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the connectors cannot be used for union creation. For example, they cannot be from the same element, they must be of the same domain and shape, and the owner of the connector1 should be a (flex) duct or pipe. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when union fitting cannot be created. |