Document
New
|
Add a new family instance of an union fitting into the Autodesk Revit document,
using two connectors.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- connector1 Connector
- The first connector to be connected to the union.
- connector2 Connector
- The second connector to be connected to the union.
Return Value
FamilyInstanceIf creation was successful then a family instance to the new union object is returned, otherwise an exception with failure information will be thrown. In the case of successful creation with another fitting type, may be returned.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument connector1 or connector2 is . |
ArgumentException | Thrown when the connectors cannot be used for union creation. For example, they cannot be from the same element, they must be of the same domain and shape, and the owner of the connector1 should be a (flex) duct or pipe. |
InvalidOperationException | Thrown when union fitting cannot be created. |